Программирование HTML Максимальная версия PHP для Joomla 1.5 Thu, May 30 2024  

Поделиться

Нашли опечатку?

Пожалуйста, сообщите об этом - просто выделите ошибочное слово или фразу и нажмите Shift Enter.

Максимальная версия PHP для Joomla 1.5 Печать
Добавил(а) microsin   

У меня есть клиент на старой Joomla 1.5, который пока не хочет делать её апгрейд, но ему надо обновить сервер. Какая максимальная версия PHP может быть установлена, чтобы Joomla 1.5 нормально заработала?

Ответы на этот вопрос на joomla.stackexchange.com [1]:

A01. Если у вас Joomla 1.5.14 или более старая, то нужно склоняться к PHP 5.2, поскольку могут быть некоторые функции и/или части кода, которые не работают на 5.3.

Однако если у вас Joomla 1.5.15 или выше, то все должно быть нормально на PHP 5.3. Если вы используете библиотеку OpenID, то это не будет совместимо с PHP 5.3, и вам понадобится искать альтернативу этой библиотеке, либо откатиться на PHP 5.2.

Рекомендую вам сделать апгрейд до Joomla 1.5.26, это последняя версия из серии 1.5.

Комментарии к A01:

- У меня несколько сайтов на Joomla 1.5.26, нормально работающих на Joomla 5.4. Хотя понадобилось запретить строгую проверку на ошибки (disable the strict standard errors), как было рекомендовано на stackoverflow.com [2].
- У меня несколько Joomla 1.5.26 patched / 1.5.999, работающих на php 5.4.28, где просто запрещены strict warnings.
- С PHP 5.3 проблемы есть только у Joomla 1.0 (есть неофициальный патч для использования J1.0 с PHP5.3), и Joomla 1.5 работает с PHP 5.4.x.
- Проект Joomla 1.5 не тестировался официально на PHP 5.4, так что нельзя быть уверенным, что этот вариант будет работать. Поэтому рекомендуется использовать PHP 5.3.

A02. У меня Joomla 1.5.26 вместе с новым сайтом J3, находящимся в разработке, на той же самой инсталляции PHP. Сайт J1.5 отлично себя чувствует на PHP 5.6 без каких-либо изменений. Сайт J1.5 очень простой, на котором стоит только несколько расширений.

Комментарии к A02:

- Подтверждаю, у меня несколько разных сайтов Joomla 1.5.26, нормально работающих на PHP 5.6. 

A03. Могу подтвердить, что Joomla 1.5.24 работает на PHP 5.5.9-1ubuntu4.17. PHP-FPM был установлен с помощью apt. В качестве веб-сервера используется nginx. Все функции выглядят нормально работающими.

[Ссылки]

1. What is the maximum version of PHP that Joomla 1.5 will run? site:joomla.stackexchange.com.
2. Disabling Strict Standards in PHP 5.4 site:stackoverflow.com.

 

Добавить комментарий


Защитный код
Обновить

Top of Page